题目描述
现在有两个人在玩石头剪子布游戏,请你判断最后谁赢了。
用R代表石头,S代表剪子,P代表布。
输入格式
输入的第一行是一个整数t(0<t<1000),表示测试样例的数目。
每组输入样例的第一行是一个整数n(0<n<100),表示游戏次数。
接下来n行,每行由两个字母组成,两个字母之间用一个空格分隔,这些字母只会是R,S或P。
第一个字母表示Player1的选择,第二个字母表示Player2的选择。
输出
对于每组输入样例,输出获胜方的名字(Player1或Player2),如果平均,则输出TIE。
样例输入
3
2
R P
S R
3
P P
R S
S R
1
P R
样例输出
Player 2
TIE
Player 1
#include <iostream>
using namespace std;
int main()
{
int t;
cin>>t;
int count1,count2;
char c1,c2;
for(int i=0;i<t;i++)
{
count1=0;
count2=0;
int n;
cin>>n;
for(int j=0;j<n;j++)
{
cin>>c1>>c2;
if(c1=='R')
{
if(c2=='S')
count1++;
else if(c2=='P')
count2++;
else if(c2=='R')
{
count1++;
count2++;
}
}
else if(c1=='P')
{
if(c2=='R')
count1++;
else if(c2=='S')
count2++;
else if(c2=='p')
{
count1++;
count2++;
}
}
else if(c1=='S')
{
if(c2=='R')
count2++;
else if(c2=='P')
count1++;
else if(c2=='S')
{
count1++;
count2++;
}
}
}
if(count1>count2)
cout<<"Player 1"<<endl;
else if(count1<count2)
cout<<"Player 2"<<endl;
else
cout<<"TIE"<<endl;
}
return 0;
}