N! hdu1042

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44441    Accepted Submission(s): 12581


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
 

Author
JGShining(极光炫影)
 
 
 
直接套用阶乘模板就得了
 
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{

    int i,j,k,m;
    int a[100004];
    while(scanf("%d",&m)!=EOF)
    {
     int len=1;
     int tem,jin=0;
     if(m==0)
     printf("1\n");
     else if(m==1)
     printf("1\n");
     else
     {
         
         memset(a,0,sizeof(a));
         a[1]=1;
         len=1;
         for(i=2;i<=m;i++)
         {
             jin=0;
             for(j=1;j<=len;j++)
             {
                 tem=a[j]*i+jin;
                 a[j]=tem%10;
                 jin=tem/10;
                 if(j==len&&jin!=0)
                 len++;
                
             }
         }
     for(i=len;i>=1;i--)
     cout<<a[i];
     cout<<endl;
     }
    }
    return 0;

}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值