Ultra-QuickSort poj 2299 归并排序

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 35993 Accepted: 12965

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
 
 
 
交换相邻的元素,求至少交换多少次可以使其成递增的排序,如果用冒泡的话肯定会超时的,只能用归并排序,求其逆序数,
逆序数也就是它的交换数,所以用归并排序就是了!!!!


#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int a[500000];
int sw[500000];
int n;
long long num;
void merge(int low,int mid,int high)
{

     int i=low;
     int j=mid+1;
     int m=0;
     while(i<=mid&&j<=high)
     {
         if(a[i]<=a[j])
         {
             sw[m++]=a[i];
             i++;



         }
         else
         {

             sw[m++]=a[j];
             j++;
             num=num+mid-i+1;
         }
     }
     while(i<=mid)
     {

         sw[m++]=a[i];
         i++;
     }
      while(j<=mid)
     {

         sw[m++]=a[j];
         j++;
     }
     for(i=0;i<m;i++)
     {
         a[low+i]=sw[i];
     }
}
void mergesort(int low,int high)
{
     if(low<high)
     {
         int mid=(low+high)/2;
         mergesort(low,mid);
         mergesort(mid+1,high);
         merge(low,mid,high);
     }
}
int main()
{

    int i,j;
    int n;
    while(scanf("%d",&n)!=EOF)
    {
     if(n==0)
     break;
     num=0;
     for(i=0;i<n;i++)
     scanf("%d",&a[i]);
     mergesort(0,n-1);
     cout<<num<<endl;





    }

    return 0;
}









 

                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值