hdu 1673



Optimal Parking

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1524    Accepted Submission(s): 1300


Problem Description
When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs.
Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?
Long Street is a straight line, where all positions are integer.
You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.
 


Input
The first line of input gives the number of test cases, 1 <= t <= 100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1 <= n <= 20, and the second gives their n integer positions on Long Street, 0 <= xi <= 99.
 


Output
Output for each test case a line with the minimal distance Michael must walk given optimal parking.
 


Sample Input
  
  
2 4 24 13 89 37 6 7 30 41 14 39 42
 


Sample Output
  
  
152 70
 


Source
 


Recommend
lcy   |   We have carefully selected several similar problems for you:   1677  1676  1672  1675  1674 




这个题目是说有一个街,街上面有很多商店,我们要选一个停车,然后全逛一遍,所以肯定要把这个街全都找一遍,所以肯定是要把这个街逛两遍,直接求街的二倍就行了。



#include<iostream>
#include<stdlib.h>
using namespace std;
int stores[25];
int cmp(const void *a,const void *b){
    return *(int *)a-*(int *)b;
}
int main(){
    int t;
    int n;
    cin>>t;
    while(t--){
        cin>>n;
        int i;
        for(i=0;i<n;i++)
            cin>>stores[i];
        qsort(stores,n,sizeof(int),cmp);
        cout<<(stores[n-1]-stores[0])*2<<endl;
    }
    return 0;
}




 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值