杭电oj 1009

先看题目

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 57721    Accepted Submission(s): 19329


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 


Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 


Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 


Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 


Sample Output
  
  
13.333 31.500
 
题目的意思是FatMouse用CatFood交换JavaBean(JavaBean乱入,哈哈,博主有空写一个关于javaBean的博客),FatMouse拥有M的CatFood,然后要交换最多的Javabean。
很明显是贪心算法,我们对JavaBean/CatFood进行排序,问题就很容易解决了,还有要注意的是,当M=0和N=0时的情况
下面贴上我的代码
#include <iostream>
#include <algorithm>
#include <iomanip>
using namespace std;
struct Rate 
{
	double javaBean;
	double catFood;
	double rat;
}rate[1000];
bool cmp(const Rate &a,const Rate &b)
{
	if(a.rat>b.rat)
		return true;
	else
		return false;
}

int main()
{
	int M,N;
	int i;
	double sum;
	while(cin>>M>>N&&M!=-1&&N!=-1)
	{
		sum=0;
		if(N!=0)
		{
			for(i=0;i<N;i++){
			cin>>rate[i].javaBean>>rate[i].catFood;
			rate[i].rat=rate[i].javaBean/rate[i].catFood;
			}
			sort(rate,rate+N,cmp);
			i=0;
			while(M>0)
			{
				if(M>rate[i].catFood)
				{
					M-=rate[i].catFood;
					sum+=rate[i].javaBean;
				}
				else
				{
					sum+=rate[i].rat*M;
					break;
				}
				i++;
			}
		}
		
		cout<<setprecision(3)<<std::fixed<<sum<<endl;
	}
	return 0;
}
ac了

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值