HDU-Clairewd’s message-4300

这题太坑爹了,英语不好翻译了好几个小时,题目大意是:第一行是密文转明文是转换表,第二行是文件,前面是密文,后面是原文,但那个人接到这个文件后不知道中间从哪里开始是原文,明文可能不全,但密文是完整的,所以你要帮忙还原一下,如果后面原文比密文少,你就将它补全。

思路:将文件转换成明文,再把原文件的后一半接到转换后的字符串后,但中间要用“#”连接,之后把字符串next[]数组,找到前缀和后缀的最长相等长度,当然,在比较时要注意,原文件密文长度肯定要>=明文长度,所以在匹配的时候,要保证前面比后面长,以免出现错误。

 

Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2572    Accepted Submission(s): 1010


Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
    Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
    But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
    Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 


 

Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;
 


 

Output
For each test case, output one line contains the shorest possible complete text.
 


 

Sample Input
  
  
2 abcdefghijklmnopqrstuvwxyz abcdab qwertyuiopasdfghjklzxcvbnm qwertabcde
 


 

Sample Output
  
  
abcdabcd qwertabcde
 

#include<iostream>
#include<cstring>
#include <cstdio>
using namespace std;
char t[100006],s[200006],str1[26];
int next[200006],str[100006];
int getnext()
{
    int i=0,j=-1;
    next[0]=-1;
    int len=strlen(s);
    while(i<len)
    {
        if(j==-1||s[i]==s[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
    return j;
}

int main()
{
    int text,j;
    scanf("%d",&text);
    while(text--)
    {
        memset(s,0,sizeof(s));
        memset(str1,0,sizeof(str1));
        char ch;
        int i;
        scanf("%s",str1);
        for(i=0;i<26;i++)
        {
            ch=str1[i];
            str[ch]=i;
        }
        scanf("%s",t);
        int lent=strlen(t);
        for(i=0;i<lent;i++)
        {
            int temp=str[t[i]];
            s[i]=temp+'a';
        }
        s[i]='#';
        if(lent%2==1)
        i=lent/2+1;
        else
        i=lent/2;
        for(j=lent+1;i<lent;i++,j++)
        s[j]=t[i];
        int j=getnext();
        if(j*2==lent)
        {
            printf("%s\n",t);
        }
        else
        {
            int tmp1=lent-j;
            printf("%s",t);
            for(i=j;i<tmp1;i++)
                printf("%c",s[i]);
            printf("\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值