题目大意:一个四位数,可加一,9+1=1,可减一,1-1=9,可左右互换,但最左和最右不能换,要多少步换到第二个四位数。
广搜拓展一下,向三个方向。
Open the Lock
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3055 Accepted Submission(s): 1346
Problem Description
Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9.
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.
Now your task is to use minimal steps to open the lock.
Note: The leftmost digit is not the neighbor of the rightmost digit.
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.
Now your task is to use minimal steps to open the lock.
Note: The leftmost digit is not the neighbor of the rightmost digit.
Input
The input file begins with an integer T, indicating the number of test cases.
Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.
Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.
Output
For each test case, print the minimal steps in one line.
Sample Input
2 1234 2144 1111 9999
Sample Output
2 4
#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;
struct nobe
{
int num[4],step;
};
queue<nobe> q;
int visit[15][15][15][15];
int x,y;
void BFS(int x)
{
nobe que,ue;
int i;
for(i=0; i<4; i++)
{
que.num[3-i]=x%10;
x/=10;
}
que.step=0;
visit[que.num[0]][que.num[1]][que.num[2]][que.num[3]]=1;
q.push(que);
while(!q.empty())
{
que=q.front();
q.pop();
if(que.num[0]*1000+que.num[1]*100+que.num[2]*10+que.num[3]==y)
{
printf("%d\n",que.step);
}
for(i=0; i<4; i++)//加一
{
ue=que;
if(que.num[i]==9)
ue.num[i]=1;
else
ue.num[i]=ue.num[i]+1;
if(!visit[ue.num[0]][ue.num[1]][ue.num[2]][ue.num[3]])
{
visit[ue.num[0]][ue.num[1]][ue.num[2]][ue.num[3]]=1;
ue.step=que.step+1;
q.push(ue);
}
}
for(i=0; i<4; i++)//减一
{
ue=que;
if(que.num[i]==1)
ue.num[i]=9;
else
ue.num[i]=ue.num[i]-1;
if(!visit[ue.num[0]][ue.num[1]][ue.num[2]][ue.num[3]])
{
visit[ue.num[0]][ue.num[1]][ue.num[2]][ue.num[3]]=1;
ue.step=que.step+1;
q.push(ue);
}
}
for(i=0; i<3; i++) //互换
{
ue=que;
ue.num[i]=que.num[i+1];
ue.num[i+1]=que.num[i];
if(!visit[ue.num[0]][ue.num[1]][ue.num[2]][ue.num[3]])
{
visit[ue.num[0]][ue.num[1]][ue.num[2]][ue.num[3]]=1;
ue.step=que.step+1;
q.push(ue);
}
}
}
}
int main()
{
int i,k;
cin>>k;
for(i=0; i<k; i++)
{
memset(visit,0,sizeof(visit));
if(i)
getchar();
cin>>x>>y;
BFS(x);
}
}