hdu-1312-Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9752 Accepted Submission(s): 6072


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

Sample Output
  
  
45 59 6 13
以前做过,这次用广搜又水了一遍
#include<stdio.h>
#include<string.h>
char map[22][22],que[410][2];
int a[4]={1,-1,0,0};
int b[4]={0,0,1,-1};
int n,m,sum;
void bfs(int x,int y)
{
    int low,top,i,j,x1,y1;
    low=top=0;
    que[0][0]=x;
    que[0][1]=y;
    top++;
    map[x][y]='#';
    while(low<top)
    {
        for(i=0;i<4;i++)
        {
            x1=que[low][0]+a[i];
            y1=que[low][1]+b[i];
            if(x1>=0&&x1<n&&y1>=0&&y1<m&&map[x1][y1]!='#')
            {
                que[top][0]=x1;
                que[top][1]=y1;
                top++;
                map[x1][y1]='#';
                sum++;
            }
        }
        low++;
    }
}
int main()
{
    int i,j,x,y;
    while(scanf("%d%d",&m,&n)&&m+n)
    {
        getchar();
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j]=='@')
                {
                    x=i;
                    y=j;
                }
            }
            getchar();
        }
        sum=0;
        bfs(x,y);
        printf("%d\n",sum+1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值