九度oj-1001-A+B for Matrices

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:13860

解决:5673

题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5
来源:
2011年浙江大学计算机及软件工程研究生机试真题
import java.util.Scanner;
public class Main {
    static int i,j,k;
	static int [][]a=new int[12][12];
	static int [][]b=new int[12][12];
	public static void main(String[] args){
		Scanner in=new Scanner(System.in);
		while(true){
			int m=in.nextInt();
			if(m==0) break;
			int n=in.nextInt();
			for(i=0;i<m;i++)
				for(j=0;j<n;j++)
					a[i][j]=in.nextInt();
			for(i=0;i<m;i++)
				for(j=0;j<n;j++){
					b[i][j]=in.nextInt();
					a[i][j]+=b[i][j];
				}
			k=0;
			for(i=0;i<m;i++){
				for(j=0;j<n;j++)
					if(a[i][j]!=0) break;
				if(j==n) k++;
			}
			for(j=0;j<n;j++){
				for(i=0;i<m;i++)
					if(a[i][j]!=0) break;
				if(i==m) k++;
			}
			System.out.println(k);
		}
		in.close();
	}
}
	


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值