hdoj-1097-A hard puzzle

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52469    Accepted Submission(s): 19190


 

Problem Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

 

 

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

 

 

Output

For each test case, you should output the a^b's last digit number.

 

 

Sample Input

 

7 66 8 800

 

 

Sample Output

 

9 6

 

 

Author

eddy

 

解题的思路主要是找规律,发现所有数的n次幂的个位数都是有一定规律的:个位上的数是以4为周期交替出现的。

AC代码:

#include<stdio.h>
int main()
{
	int a,b,m;
	while(scanf("%d%d",&a,&b) != EOF)
	{
		a %= 10;
		b %= 4;
		b = b?b:4;
		m = 1;
		for(int i=0;i<b;i++)
			m = m*a;
		printf("%d\n",m%10);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值