HDOJ-----1097简单快速幂

Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
  
  
7 66 8 800
 

Sample Output
  
  
9

6

同余定理主要性质

(1)对于同一个除数,两数的和(或差)于他们余数的和(或差)同余数。(a + b) % c = (a % c + b % c) % c

(2)对于同一个除数,两数的乘积与他们余数的乘积同余。a * b % c = (a % c) * (b % c) % c

(3)对于同一个除数,如果两个整数同余,那么他们的差就一定能被这个数整除。a % c = b % c 则 (a - b) % c = 0

(4)对于同一个除数,如果两个整数同余,那么他们的乘方仍然同余。a % c = b % c 则 a^n % c = b^n % c

给定两个数a、b,求a的b次方最后一位数字,即a的b次方对10取余的快速幂

#include<cstdio>
int main(){
    int a, b, c;
    while(~scanf("%d%d", &a, &b)){
        int ans = 1;
        a %= 10;
        while(b > 0){
            if(b & 1){
                ans = (ans * a) % 10;
            }
            b >>= 1;
            a = (a * a) % 10;
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值