UVA 10106 Product(大数乘法)

The Problem

 
The problem is to multiply two integers X, Y. (0<=X,Y<10250)
 

The Input

 
The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.
 

The Output

 
For each input pair of lines the output line should consist one integer the product.
 

Sample Input

 
 
 12
12
2
222222222222222222222222
 
 
 

Sample Output

 
 
 144
444444444444444444444444


代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>

using namespace std;

void bigmul(char *a,char *b,char *c)
{
    int la,lb,lc,i,j,aa[1000],bb[1000],cc[3000],t,n;
    la=strlen(a)-1;
    lb=strlen(b)-1;
    for(i=la,j=0;i>=0;i--)  aa[j++]=a[i]-'0';
    for(i=lb,j=0;i>=0;i--)  bb[j++]=b[i]-'0';
    memset(cc,0,sizeof(cc));
    for(i=0;i<=la;i++)
        for(j=0;j<=lb;j++)
           cc[i+j]+=aa[i]*bb[j];
    for(i=0;i<=la+lb+5;i++)
    {  t=cc[i]/10;
        cc[i+1]+=t;
        cc[i]=cc[i]-t*10;}
    for(i=la+lb+5;i>=0;i--)
          if(cc[i]!=0)
            break;

  if(i==-1)
    strcpy(c,"0");
else
 {  n=i;
  for(i=0,j=n;i<j;i++,j--)
  {
       t=cc[i];cc[i]=cc[j];cc[j]=t;
  }

   for(i=0;i<=n;i++)
     c[i]=cc[i]+'0';
  c[i]='\0';
  }
 }

int main()
{
    char b[1000],a[1000],c[2000];
    while(~scanf("%s%s",a,b))
    {
        bigmul(a,b,c);
        printf("%s\n",c);
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值