苗大神教我的拓扑排序,欧耶!!!

DescriptionDandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number. InputOne line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's. OutputFor every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1. Sample Input2 11 22 21 22 1 Sample Output1777-1

#include <iostream>
#include <algorithm>
#include<cstring>
#include<cstdio>
#include<queue>
#include<vector>
using namespace std;

const int maxn=10010;
int n,m;
int sum[maxn];
queue<int>q;
int N;
int ans;

struct Node{
 vector<int>son;
 int pr;
 int ne;
}node[maxn];

int main()
{  int x,y;
    while(~scanf("%d%d",&n,&m))
    {
        N=0;

        memset(node,0,sizeof(node));
        for(int i=1;i<=m;i++)
        {scanf("%d%d",&x,&y);
           node[y].ne++;
           node[x].pr++;
           node[y].son.push_back(x);
        }
        for(int i=1;i<=n;i++)
            if(node[i].pr==0)
            q.push(i),sum[i]=888;
          while(!q.empty())
          {
              int z=q.front();
              q.pop(),N++;
              for(int i=0;i<node[z].ne;i++)
              {
                  node[node[z].son[i]].pr--;
                  if(!node[node[z].son[i]].pr)
                    q.push(node[z].son[i]),sum[node[z].son[i]]=sum[z]+1;
              }
          }

          if(N<n)
              printf("-1\n");
          else
          {
              ans=0;
            for(int i=1;i<=n;i++)
                ans+=sum[i];
            printf("%d\n",ans);
          }
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值