A - Marbles

这题很好,不过我真的是想了很久,在别人的指点下,先用递归试了可以,但是太慢,再改成dp,交上去time limit ,题目所给的T<=10000,所以对dp数组预处理,交上去一下子过了,0.016,代码比我刚开始想用数学方法排列组合写简短多了,那个数学方法有漏洞,这题的状态是 r 个 红球 b 个蓝球下的概率

dp[2][5] = 2/7  * dp[1][4] + 5/7  *  dp[2][3]

dp[1][4] = 1/5  * dp[0][3] + 4/5  * dp[1][2]

dp[2][3] = 2/5 * dp[1][2] +( 3/5  * dp[2][1])   i>j  为0  以此类推

dp[i][0]=0  dp[0][i]=1;

Description

Your friend Jim has challenged you to a game. He has a bag containing red and blue marbles. There will be an odd number of marbles in the bag, and you go first. On your turn, you reach into the bag and remove a random marble from the bag; each marble may be selected with equal probability. After your turn is over, Jim will reach into the bag and remove a blue marble; if there is no blue marble for Jim to remove, then he wins. If the final marble removed from the bag is blue (by you or Jim), you will win. Otherwise, Jim wins.

Given the number of red and blue marbles in the bag, determine the probability that you win the game.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case begins with two integers R and B denoting the number of red and blue marbles respectively. You can assume that 0 ≤ R, B ≤ 500 and R+B is odd.

Output

For each case of input you have to print the case number and your winning probability. Errors less than 10-6 will be ignored.

Sample Input

5

1 2

2 3

2 5

11 6

4 11

Sample Output

Case 1: 0.3333333333

Case 2: 0.13333333

Case 3: 0.2285714286

Case 4: 0

Case 5: 0.1218337218


#include<stdio.h>
#include<algorithm>
using namespace std;
double dp[550][550];
/*double f(int x,int y)
{
	if(x==0)  return 1;
	if(x>y)   return 0;
	return 1.0*x/(x+y)*f(x-1,y-1)+1.0*y/(x+y)*f(x,y-2);
}*/
int main()
{
	int r,t,b,ca=1;
	scanf("%d",&t);
	for(int i=1;i<=500;i++)
		{
			dp[0][i]=1;
			dp[i][0]=0;     
		}
		for(int i=1;i<=500;i++)
		{
			for(int j=2;j<=500;j++)  if(i<j)
			{
				dp[i][j]=1.0*i/(i+j)*dp[i-1][j-1]+1.0*j/(i+j)*dp[i][j-2];
			}
		}	 	
	while(t--)
	{
		scanf("%d%d",&r,&b);	       								
        printf("Case %d: %lf\n",ca++,dp[r][b]);	  				
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值