F - Red and Black

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45

59

6

13

#include<stdio.h>
int m,n,cnt;
int to[4][2]={{0,-1},{0,1},{1,0},{-1,0}};
char a[25][25];
void dps(int i,int j)
{
	cnt++;
	a[i][j]='#';
	for(int k=0;k<4;k++)
	{
	   int x=i+to[k][0];
	   int y=j+to[k][1];
	   if(x>=0 && x<n && y>=0 && y<m &&a[x][y]=='.')
	     dps(x,y); 
	}
}
int main()
{
	while(~scanf("%d%d",&m,&n),m||n)
	{
		cnt=0;
		int fi,fj;
		getchar();
		for(int i=0;i<n;i++)
		{
		   for(int j=0;j<m;j++)
		   {
		  	 scanf("%c",&a[i][j]);
		  	 if(a[i][j]=='@')
		  	 {
		  	 	fi=i;
		  	 	fj=j;
		  	 }
 		   } 
		   getchar();
		}
 		dps(fi,fj);
		printf("%d\n",cnt);    
	}
	
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
gmx xpm2ps -f dssp.xpm -o secondary-structure.eps -title none -di 1.m2p -rainbow red可以将xom文件转化成eps,请修改以下代码,使其只显示只显示alpha-helix与beta-sheet,使alpha-helix用蓝色表示,beta-sheet用黄色表示。; Command line options of xpm2ps override the parameters in this file black&white = no ; Obsolete titlefont = Times-Roman ; A PostScript Font titlefontsize = 20 ; Font size (pt) legend = yes ; Show the legend legendfont = Times-Roman ; A PostScript Font legendlabel = ; Used when there is none in the .xpm legend2label = ; Used when merging two xpm’s legendfontsize = 14 ; Font size (pt) xbox = 2.0 ; x-size of a matrix element ybox = 2.0 ; y-size of a matrix element matrixspacing = 20.0 ; Space between 2 matrices xoffset = 0.0 ; Between matrix and bounding box yoffset = 0.0 ; Between matrix and bounding box x-major = 20 ; Major ticks on x axis every … frames x-minor = 5 ; Id. Minor ticks x-firstmajor = 0 ; First frame for major tick x-majorat0 = no ; Major tick at first frame x-majorticklen = 8.0 ; x-majorticklength x-minorticklen = 4.0 ; x-minorticklength x-label = ; Used when there is none in the .xpm x-fontsize = 16 ; Font size (pt) x-font = Times-Roman ; A PostScript Font x-tickfontsize = 10 ; Font size (pt) x-tickfont = Helvetica ; A PostScript Font y-major = 20 y-minor = 5 y-firstmajor = 0 y-majorat0 = no y-majorticklen = 8.0 y-minorticklen = 4.0 y-label = y-fontsize = 16 y-font = Times-Roman y-tickfontsize = 10 y-tickfont = Helvetica
06-10

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值