HDU 1242 BFS+优先队列

Rescue

 

Problem Description

 

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 


 

Input

 

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.  

Process to the end of the file.
 


 

Output

 

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."  
 


 

Sample Input

 

  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 


 

Sample Output

 

  
  
13


 

题意:

天使的朋友去救天使,从r开始遍历,步数依次+1,遇x则+2。判断书否能够救出天使。

#include <iostream>
#include <queue>
using namespace std;
const int N=201;
class persion 
{
public:
	int x,y;
	int time;
	friend bool operator < (const persion &a,const persion &b)  
	{  
		return a.time>b.time;
	}  

};
int dire[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
char map[N][N];
int vis[N][N];
int a,b;
int bfs(int x,int y)
{
	priority_queue<persion> q;//优先队列
	persion now,next;
	memset(vis,0,sizeof(vis));
	now.x=x;
	now.y=y;
	now.time=0;
	vis[now.x][now.y]=1;
	q.push(now);
	while (!q.empty())//队列为空结束
	{
		now=q.top();
		q.pop();
		for(int i=0;i<4;i++)
		{
			next.x=now.x+dire[i][0];
			next.y=now.y+dire[i][1];
			if(next.x>=0&&next.x<a&&next.y>=0&&next.y<b&&map[next.x][next.y]!='#'&&!vis[next.x][next.y])  
			{//判断是否越界、墙壁、或者走过
				if(map[next.x][next.y]=='r')
					return now.time+1;
				if(map[next.x][next.y]=='x')
					next.time=now.time+2;//遇到x时间+2
				else
					next.time=now.time+1;
				vis[next.x][next.y]=1;
				q.push(next);
			}
		}
	}
	return -1;
}

int main()
{
	int i,j;
	persion angle;
	while(cin>>a>>b)
	{
		for(i=0;i<a;i++)
		{
			for(j=0;j<b;j++)
			{
				cin>>map[i][j];
				if(map[i][j]=='a')
					angle.x=i,angle.y=j;//记录初始位置
			}
		}
		int time=bfs(angle.x,angle.y);
		if(time==-1)
			cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
		else
			cout<<time<<endl;
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值