HDU 1085 母函数

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12117    Accepted Submission(s): 5420


Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!  
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!  
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

Sample Input
  
  
1 1 3 0 0 0
 

Sample Output
  
  
4


给你 1, 2 , 5 的面额硬币的数量 让你去找 最小不能得到的价值

感觉有点无语了,

这个题目只要考虑一下特殊情况,就水过了

直接判断的代码:

#include <iostream>
using namespace std;
int main()
{
	int a,b,c;
	while(scanf("%d%d%d",&a,&b,&c)&&(a||b||c))
	{
		if(a==0)
			printf("1\n");
		else if(a+2*b<4)
			printf("%d\n",a+2*b+1);
		else
			printf("%d\n",a+2*b+5*c+1);
	}
	return 0;
}


不过还是用母函数做了一遍..

#include <iostream>
using namespace std;
int c1[11111],c2[11111];

int n,sum;
int main()
{
	int i,j,k;
	int y[4]={0,1,2,5},x[4];
	while(~scanf("%d%d%d",&x[1],&x[2],&x[3])&&(x[1]||x[2]||x[3]))
	{
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		for(i=0;i<=x[1];i++)
			c1[i]=1;//遍历第一个式子
		sum=x[1]+2*x[2]+5*x[3];//硬币总值
		for(i=2;i<=3;i++)//遍历2、3两个式子
		{
			for(j=0;j<=sum;j++)
			{
				for(k=0;k<=x[i]*y[i];k+=y[i])
					c2[k+j]+=c1[j];
			}
			for(j=0;j<=sum;j++)
				c1[j]=c2[j],c2[j]=0;
		}
		for(i=0;i<=sum+1;i++)
			if(c1[i]==0)break;
		printf("%d\n",i);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值