HDU 1394 线段树

Minimum Inversion Number

Problem Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

题目大意:
给一个n个数的序列a1, a2, ..., an ,这些数的范围是0~n-1, 可以把前面m个数移动到后面去,形成新序列:
a1, a2, ..., an-1, an
a2, a3, ..., an, a1

a3, a4, ..., an, a1, a2

...
an, a1, a2, ..., an-1
求这些序列中,逆序数最少的是多少?

求出a1, a2, ..., an-1, an的逆序数之后,就可以递推求出其他序列的逆序数。 假设要把a1移动到an之后,那么我们把这个过程拆分成两步:
1.  把a1去除掉。通过观察可以发现,(a1-1)是0~n-1中比a1小的数字的个数,由于a1在序列的第一个所以a1之后共有(a1-1)个比a1小,所以形成了(a1-1)对逆序数,当去除掉a1时,原序列的逆序数总数也就减少了(a1-1)个逆序数。 
2. 把a1加到an之后。0~n-1中,比a1大的数共有(n-a1)个数,由于a1现在在最后一个,也就是它前面共有(n-a1)个数比它大,即增加了(n-a1)对逆序数。
综合1,2两步, 设原序列逆序数为sum, 当把原序列第一个移动到最后位置时,逆序数变为:sum = sum-(ai-1)+(n-ai);

(方法是度娘的...)

代码是自己的..

#include <iostream>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=111111;
int sum[maxn<<2],x;
int s[maxn<<2];
void pushup(int rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
	sum[rt]=0;
	if(l==r)return;
	int m=(l+r)>>1;
	build(lson);
	build(rson);
}
void update(int l,int r,int rt,int s)
{
	if(l==r)
	{
		sum[rt]=1;
		return;
	}
	int m=(l+r)>>1;
	if(s<=m)update(lson,s);
	else if(s>m)update(rson,s);
	pushup(rt);
}
void query(int l,int r,int rt,int L,int R)
{
	if(L<=l&&R>=r)
	{
		x+=sum[rt];
		return;
	}
	int m=(l+r)>>1;
	if(L<=m)query(lson,L,R);
	if(R>m)query(rson,L,R);
}
int main()
{
	int n,i,j,min;
	while(~scanf("%d",&n))
	{
		build(0,n-1,1);
		x=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&s[i]);
			query(0,n-1,1,s[i],n-1);
			update(0,n-1,1,s[i]);
		}
		min=x;
		for(i=0;i<n;i++)
		{
			x=x-s[i]+(n-1)-s[i];
			if(min>x)
				min=x;
		}
		printf("%d\n",min);
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值