FZU A-B problem

Description

Fat brother and Maze are playing a kind of special (hentai) game by two integers A and B. First Fat brother write an integer A on a white paper and then Maze start to change this integer. Every time Maze can select an integer x between 1 and A-1 then change A into A-(A%x). The game ends when this integer is less than or equals to B. Here is the problem, at least how many times Maze needs to perform to end this special (hentai) game.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers A and B described above.

1 <= T <=100, 2 <= B < A < 100861008610086

Output

For each case, output the case number first, and then output an integer describes the number of times Maze needs to perform. See the sample input and output for more details.

Sample Input

2
5 3
10086 110

Sample Output

Case 1: 1
Case 2: 7

题目分析:

A -  (A%x)  ,x 取过大或者过小都不合适,所以最好的是取中间

#include <iostream>
#include <cstdio>
#include <cstring>
#include <iomanip>
using namespace std;
long long  a, b;
long t;
void solve(long long a, long long  b)
{
    long sum = 0;
    while (a > b)
    {
        a -= ((a - 1) / 2);
        sum++;
    }
    printf("%d\n", sum);


}
int main()
{
    cin>>t;
    for (long i = 1; i <= t; i++)
    {
        scanf("%I64d%I64d\n", &a, &b);
        printf("Case %d: ", i);
        solve(a, b);

    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值