【DP】poj 1159_Palindrome_201408041527

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 52497 Accepted: 18097

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

 
 
题意:给你一个字符串,问至少添加几个字符能变成一个回文字符串
 
解题思路:
 
把字符串翻转过来,求两个字符串的最长公共子序列(LCS)
 
难点:求LCS
 
重点:给的内存是65536k,如果开一个int[5050][5050]肯定要超内存的,这时候怎么办,动态数组便出现。。。
 
详见代码:
 
#include <stdio.h>
#include <string.h>

char str[5050],str2[5050];
int ans[2][5050];

int max(int a,int b)
{
    return a > b ? a : b ;
}
int main()
{
    int i,j,n;
    memset(ans,0,sizeof(ans));
    memset(str,0,sizeof(str));
    memset(str2,0,sizeof(str2));
    scanf("%d",&n);
    scanf("%s",str);
    for(j=0,i=n-1;i>=0;i--)
    str2[j++]=str[i];
    //puts(str);
    //puts(str2);
    for(i=0;i<n;i++)
    {
        for(j=0;j<n;j++)
        {
            if(str[i]==str2[j])
            ans[(i+1)%2][j+1]=ans[i%2][j]+1;//动态数组 
            else
            ans[(i+1)%2][j+1]=max(ans[i%2][j+1],ans[(i+1)%2][j]);//动态数组 
        }
    }
    printf("%d\n",n-ans[n%2][n]);
    //system("pause");
    return 0;
}

 
那个MLE的是开的int[5050][5050]数组的运行结果
 
 
体会:第一次使用滚动数组,可以节省很多很多空间,用起来也比较简单
 
例如本题,只用到了上一行和这一行的数据,也就是说每次只用两行而已其余的遍历过久没用了,所以开一个int[2][5050]的数组即可,重复使用这两行
 
 
标签:DP,滚动数组
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值