POJ 一 2388 Who's in the Middle

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output

* Line 1: A single integer that is the median milk output.

Sample Input

5
2
4
1
3
5

Sample Output

3

Hint

INPUT DETAILS: 

Five cows with milk outputs of 1..5 

OUTPUT DETAILS: 

1 and 2 are below 3; 4 and 5 are above 3.

题目意思是找出一堆数据中间的那个数。
可采用排序实现。
使用分治法递归排序较为快速。
#include <stdio.h>
int a[10000], b[10000];

void merge_sort(int x, int y)
{
    int m=x+(y-x)>>1;
    int p=x,q=m,i=x;
    if(y-x>1)
    {
     merge_sort(x,m);
     merge_sort(m,y);
     while(p<m||q<y)
     {
      if(q>=y||(p<m&&a[p]<=a[q])) 
      b[i++]=a[p++];
      else 
      b[i++]=a[q++];
     }
     for(i=x;i<y;i++) 
     a[i]=b[i];
    }
}
int main()
{
    int n,i;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    scanf("%d",a+i);//可以节省时间 
    merge_sort(0,n);
    printf("%d\n",b[n>>1]);//>>1表示除以2,可以节省时间 
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值