UVa 10010 - Where's Waldorf?

  Where's Waldorf? 

Given a  m  by  n  grid of letters, (  $1 \leq m,n \leq 20$ ), and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e. upper and lower case letters are to be treated as the same). The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid.

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The input begins with a pair of integers, m followed by n$1 \leqm,n \leq 50$ in decimal notation on a single line. The next m lines contain n letters each; this is the grid of letters in which the words of the list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters, another integer k appears on a line by itself ( $1 \leq k \leq 20$). The next k lines of input contain the list of words to search for, one word per line. These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output. The integers must be separated by a single space. The first integer is the line in the grid where the first letter of the given word can be found (1 represents the topmost line in the grid, and m represents the bottommost line). The second integer is the column in the grid where the first letter of the given word can be found (1 represents the leftmost column in the grid, and n represents the rightmost column in the grid). If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e. the occurence which places the first letter of the word closest to the top of the grid). If two or more words are uppermost, the output should correspond to the leftmost of these occurences. All words can be found at least once in the grid.

Sample Input 

1

8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert

Sample Output 

2 5
2 3
1 2
7 8



Miguel Revilla 
2000-08-22

题目不难,我写的代码太挫了。。。写了150+行尴尬

在给出的字符方块中找到与下面给出的字符串匹配的字符串的首字母位置

我采取的方法就是遍历,因为时间限制是3秒,另外我也想不到什么好方法。。。

题目中一个大坑就是输入多组数据时要输出换行

UVa把输出错误当做WA。。。让我无语

代码如下:

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cctype>
#include <cstring>
#include <string>
#include <vector>
#include <map>
#define MAXN 52
#define INF 0x7FFFFFFF
#define ll long long
using namespace std;
char ch[MAXN][MAXN];
int main(void){
	int N;
	scanf("%d", &N);
	for(int I=1; I<=N; ++I){
		int m, n;
		scanf("%d%d", &m, &n);
		if(I >= 2) printf("\n");//绝逼一大坑!!! 
		for(int i=1; i<=m; ++i){
			getchar();//处理输入的换行符 
			for(int j=1; j<=n; ++j){
				scanf("%c", &ch[i][j]);
				ch[i][j] = tolower(ch[i][j]);
			}
		}
		getchar();
		
		int T;
		cin >> T;
		string str;
		while(T--){
			cin >> str;
			
			int len = str.size();
			for(int i=0; i<len; ++i){
				str[i] = tolower(str[i]);
			}
			
			int flag = 0;
			for(int i=1; i<=m; ++i){
				for(int j=1; j<=n; ++j){
					if(str[0] == ch[i][j]){
						//分八种情况
						
						//第一种情况截取正上方  
						if(i >= len){ 
							string cpstr;
							for(int k=0; k<len; ++k){
								cpstr.push_back(ch[i-k][j]);
							}
							if(cpstr == str){
							 cout << i << " " << j << endl;
							 flag = 1;
							 break;
						    }
						} 
						
						if(min(i, j) >= len){//第二种情况截取左上角
						 	string cpstr;
						 	for(int k=0; k<len; ++k){
						 		cpstr.push_back(ch[i-k][j-k]);
						 	}
						 	if(cpstr == str){
						 		cout << i << " " << j << endl;
						 		flag = 1;
								break;
						 	} 
						} 
						
						if(min(i, n-j+1) >= len){//第三种情况截取右上方 
							string cpstr;
							for(int k=0; k<len; ++k){
								cpstr.push_back(ch[i-k][j+k]);
							} 
							if(cpstr == str){
								cout << i << " " << j << endl;
								flag = 1;
								break; 
							}
						}
						
						if(j >= len){//第四种情况取正左方
							string cpstr;
							for(int k=0; k<len; ++k){
								cpstr.push_back(ch[i][j-k]);
							} 
							if(cpstr == str){
								cout << i << " " << j << endl;
								flag = 1;
								break;
							}
						}
						
						if(n-j+1 >= len){//第五种情况取正右方
							string cpstr;
							for(int k=0; k<len; ++k){
								cpstr.push_back(ch[i][j+k]);
							} 
							if(cpstr == str){
								cout << i << " " << j << endl;
								flag = 1;
								break; 
							}
						}
						
						//第六种情况取左下角
						if(min(m-i+1, j) >= len){
							string cpstr;
							for(int k=0; k<len; ++k){
								cpstr.push_back(ch[i+k][j-k]);
							}
							if(cpstr == str){
								cout << i << " " << j << endl;
								flag = 1;
								break;
							}
						} 
						
						int flag = 0;
						if(m-i+1 >= len){//第七种情况取正下方
							string cpstr;
							for(int k=0; k<len; ++k){
								cpstr.push_back(ch[i+k][j]);
							} 
							if(str == cpstr){
								cout << i << " " << j << endl;
								flag = 1;
								break;
							}
						} 
						
						//第八种情况取右下角
						if(min(m-i+1, n-j+1) >= len){
							string cpstr;
							for(int k=0; k<len; ++k){
								cpstr.push_back(ch[i+k][j+k]);
							}
							if(cpstr == str){
								cout << i << " " << j << endl;
								flag = 1;
								break;
							}
						}
					} 
				}
				if(flag) break;
			}
		}
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值