Radar Installation

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

这个题是和外星人的供给站是一个题,解题思路见外星人供给站这篇博客。

附代码如下:

#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<cmath>
using namespace std;
struct node{
    double x;
    double y;
}p[1001];
bool cmp(node a,node b)
{
    return a.x<b.x;
}
int main()
{
    int k,n,r,x,y,i,j;
    int t=1;
    while(cin>>n>>r&&n!=0&&r!=0)
    {
        int flag=0;
        int count=1;
        double s;
        for(i=0;i<n;i++)
        {
            cin>>x>>y;
            if(r<y)
                flag=1;
            s=sqrt(r*r-y*y);
            p[i].x=x-s;
            p[i].y=x+s;
        }
        printf("Case %d: ",t++);
        if(flag==1)
        {
            printf("-1\n");
            continue;
        }
        sort(p,p+n,cmp);
        s=p[0].y;
        for(i=0;i<n;i++)
        {
            if(p[i].x>s)
            {
                count++;
                s=p[i].y;
            }
            else
            {
                if(p[i].y<s)
                {
                    s=p[i].y;
                }
            }
        }
        cout<<count<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值