poj1442 Black Box treap

Language:
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6815 Accepted: 2753

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

Source



题意:给定一组数据按顺序插入,每次在u个元素的时候,找到第i小的数,i= 1,2,3,4...,

思路:treap求第k小,详见代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=30000+100;
int n,m;
int a[MAXN];
struct node
{
    node *ch[2];
    int r,v,s;
    node(int v):v(v)
    {
        s=1;
        r=rand();
        ch[0]=ch[1]=NULL;
    }
    bool operator <(const node &rhs) const
    {
        return r<rhs.r;
    }
    int cmp(int x)
    {
        if(x==v)
            return -1;
        return x<v ? 0:1;
    }
    void maintain()
    {
        s=1;
        if(ch[0]!=NULL) s+=ch[0]->s;
        if(ch[1]!=NULL) s+=ch[1]->s;
    }
};
struct Treap
{
    inline void rotate(node * &o,int d)
    {
        node *k=o->ch[d^1];
        o->ch[d^1]=k->ch[d];
        k->ch[d]=o;
        o->maintain(); k->maintain();
        o=k;
    }
    inline void insert(node * &o,int x)
    {
        if(o==NULL) o=new node(x);
        else
        {
            int d=(x<o->v?0:1);
            insert(o->ch[d],x);
            if(o->ch[d]->r>o->r)
                rotate(o,d^1);
        }
        o->maintain();
    }
    inline void remove(node * &o,int x)
    {
        int d=o->cmp(x);
        if(d==-1)
        {
            node *u=o;
            if(o->ch[0]!=NULL && o->ch[1]!=NULL)
            {
                int d2=(o->ch[0]->r>o->ch[1]->r? 1:0);
                rotate(o,d2);remove(o->ch[d2],x);
            }
            else
            {
                if(o->ch[0]==NULL)
                    o=o->ch[1];
                else
                    o=o->ch[0];
                delete u;
            }
        }
        else
            remove(o->ch[d],x);
        if(o!=NULL)
            o->maintain();
    }
    inline int kth(node * o,int k)
    {
        if(o==NULL || k<=0 || k>o->s) return 0;
        int s=(o->ch[0]==NULL ? 0: o->ch[0]->s);
        if(k==s+1) return o->v;
        else if(k<=s) return kth(o->ch[0],k);
        else return kth(o->ch[1],k-s-1);
    }
}treap;
int main()
{
    //freopen("text.txt","r",stdin);
    scanf("%d%d",&n,&m);
    node *rt=NULL;
    for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
    int st=1;
    for(int i=1;i<=m;i++)
    {
        int x;
        scanf("%d",&x);

        while(st<=x)
        {
            treap.insert(rt,a[st]);
            st++;
        }
        printf("%d\n",treap.kth(rt,i));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值