poj2593 Max Sequence dp

Language:
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 15356 Accepted: 6462

Description

Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N). 

You should output S. 

Input

The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.

Output

For each test of the input, print a line containing S.

Sample Input

5
-5 9 -5 11 20
0

Sample Output

40

Source



题意:从一个序列中挑两段是其两段和最大。

思路:设dp1[i]表示i之前的最大字段和,dp2[i]表示i之后的之后的最大字段和,b[i]表示以a[i]结尾的最大连续和,只不过第一段循环是从前往后,第二段是

从后往前。详见代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=100000+100;
const int inf=0x3fffffff;
int n;
int a[MAXN],b[MAXN],dp1[MAXN],dp2[MAXN];
int main()
{
    //freopen("text.txt","r",stdin);
    while(~scanf("%d",&n) && n)
    {
        dp1[0]=dp2[n+1]=-inf;
        b[0]=b[n+1]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            b[i]=max(0,b[i-1])+a[i];
            dp1[i]=max(dp1[i-1],b[i]);
        }
        for(int i=n;i>=1;i--)
        {
            b[i]=max(0,b[i+1])+a[i];
            dp2[i]=max(dp2[i+1],b[i]);
        }
        int ans=-inf;
        for(int i=1;i<n;i++)
            ans=max(ans,dp1[i]+dp2[i+1]);
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值