POJ 2593 Max Sequence

6 篇文章 0 订阅
2 篇文章 0 订阅
Max Sequence
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 17678 Accepted: 7401

Description

Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N). 

You should output S. 

Input

The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.

Output

For each test of the input, print a line containing S.

Sample Input

5
-5 9 -5 11 20
0

Sample Output

40

Source

POJ Monthly--2005.08.28,Li Haoyuan


题解:这个题2479差不多,具体可以看2479的题解,不过感觉这道题的测试数据要比2479弱一些,轻松AC

//主要是刷几道dp练练手

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int maxn = 1e6+7, inf = -1e9+7;
int a[maxn], ls[maxn], rs[maxn], rst[maxn], s;

int main()
{
    int n;
    while (~scanf("%d", &n) && n)
    {
        for (int i=0; i<n; i++)
            scanf("%d", &a[i]);
        ls[0] = a[0], rs[n-1] = rst[n-1] = a[n-1], s = inf;
        for (int i=1; i<n; i++)
            ls[i] = max(ls[i-1]+a[i], a[i]);
        for (int i=n-2; i>=0; i--)
            rs[i] = max(rs[i+1]+a[i], a[i]),
            rst[i] = max(rst[i+1], rs[i]);
        for (int i=1; i<n; i++)
            s = max(s, ls[i-1]+rst[i]);
        printf("%d\n", s);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值