poj 3565 Ants 最小权匹配

Language:
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 4210 Accepted: 1290 Special Judge

Description

Young naturalist Bill studies ants in school. His ants feed on plant-louses that live on apple trees. Each ant colony needs its own apple tree to feed itself.

Bill has a map with coordinates of n ant colonies and n apple trees. He knows that ants travel from their colony to their feeding places and back using chemically tagged routes. The routes cannot intersect each other or ants will get confused and get to the wrong colony or tree, thus spurring a war between colonies.

Bill would like to connect each ant colony to a single apple tree so that all n routes are non-intersecting straight lines. In this problem such connection is always possible. Your task is to write a program that finds such connection.

On this picture ant colonies are denoted by empty circles and apple trees are denoted by filled circles. One possible connection is denoted by lines.

Input

The first line of the input file contains a single integer number n (1 ≤ n ≤ 100) — the number of ant colonies and apple trees. It is followed by n lines describing n ant colonies, followed by n lines describing n apple trees. Each ant colony and apple tree is described by a pair of integer coordinates x and y (− 10 000  ≤ xy ≤  10 000 ) on a Cartesian plane. All ant colonies and apple trees occupy distinct points on a plane. No three points are on the same line.

Output

Write to the output file n lines with one integer number on each line. The number written on i-th line denotes the number (from 1 to n) of the apple tree that is connected to the i-th ant colony.

Sample Input

5
-42 58
44 86
7 28
99 34
-13 -59
-47 -44
86 74
68 -75
-68 60
99 -60

Sample Output

4
2
3
5
1

Source



题意:给出n个白点和n个黑点的坐标,要用n条不想交的线段把它们连接,线段端点为一个白点和一个黑点。输出n行,第i行为第i个白点所连接的黑点编号。

思路:最小权匹配。我们很容易看出这是个二分图,每个白点对应一个X节点,每个对应一个Y节点,每个黑点和每个白点相连,权值等于二者的欧几里得距离的负

值,那么求出当前图的最大权匹配就是解。若有两条线段a1-b1,a2-b2相交,那么d(a1,b1)+d(a2,b2)>d(a1,b2)+d(a2,b1),所以应该求原图的最小权匹配,即

当前图的最大权匹配,详见代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int MAXN=100+50;
const int inf=0x3fffffff;
const double eps=1e-10;
int n;
int S[MAXN],T[MAXN],ans[MAXN],link[MAXN];
double lx[MAXN],ly[MAXN],w[MAXN][MAXN];
struct node
{
    int x,y;
}B[MAXN],W[MAXN];
void update()
{
    double x=inf;
    for(int i=1;i<=n;i++) if(S[i]){
        for(int j=1;j<=n;j++) if(!T[j])
            x=min(x,lx[i]+ly[j]-w[i][j]);
    }
    for(int i=1;i<=n;i++){
        if(S[i]) lx[i]-=x;
        if(T[i]) ly[i]+=x;
    }
}
int path(int u)
{
    S[u]=1;
    for(int v=1;v<=n;v++) if(!T[v] && fabs(lx[u]+ly[v]-w[u][v])<eps){
        T[v]=1;
        if(link[v]==-1 || path(link[v]))
        {
            link[v]=u;
            return 1;
        }
    }
    return 0;
}
void KM()
{
    for(int i=1;i<=n;i++){
        lx[i]=-inf,ly[i]=0;
        for(int j=1;j<=n;j++)
            lx[i]=max(lx[i],w[i][j]);
    }
    for(int i=1;i<=n;i++){
        while(1){
            for(int j=1;j<=n;j++)
                S[j]=T[j]=0;
            if(path(i)) break;
            else update();
        }
    }
}
int main()
{
    //freopen("text.txt","r",stdin);
    while(~scanf("%d",&n)){
        for(int i=1;i<=n;i++)
            scanf("%d%d",&B[i].x,&B[i].y);
        for(int i=1;i<=n;i++)
            scanf("%d%d",&W[i].x,&W[i].y);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                w[i][j]=-sqrt((double)(B[i].x-W[j].x)*(B[i].x-W[j].x)+(double)(B[i].y-W[j].y)*(B[i].y-W[j].y));
        memset(link,-1,sizeof(link));
        KM();
        for(int i=1;i<=n;i++)
            ans[link[i]]=i;
        for(int i=1;i<=n;i++)
            printf("%d\n",ans[i]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值