hdu3555 Bomb 数位dp

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 6669    Accepted Submission(s): 2318


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

Source
 

Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:   3554  3556  3557  3558  3559 

题意:找1—n之间包含49的个数。

思路:和hdu2089差不多,只不过状态j=1的时候是没有49,但第i+1位是4罢了。

注意数据要long long,详见代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int MAXN=100;
ll n;
int bit[MAXN];
ll dp[MAXN][5];
ll dfs(int pos,int s,int flag)
{
    if(pos==-1) return s==2;
    if(flag && dp[pos][s]!=-1) return dp[pos][s];
    int x=flag ? 9 : bit[pos];
    ll ans=0;
    for(int i=0;i<=x;i++){
        if(s==2 || ( s==1 && i==9 ) ) ans+=dfs(pos-1,2,flag || i<x );
        else if( i==4 ) ans+= dfs(pos-1,1,flag || i<x );
        else  ans+=dfs(pos-1,0,flag || i<x );
    }
    if(flag) dp[pos][s]=ans;
    return ans;
}
ll solve(ll x)
{
    int len=0;
    while(x){
        bit[len++]=x%10;
        x/=10;
    }
    bit[len]=0;
    return dfs(len-1,0,0);
}
int main()
{
    //freopen("text.txt","r",stdin);
    memset(dp,-1,sizeof(dp));
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%I64d",&n);
        printf("%I64d\n",solve(n));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值