hdu4722 Good Numbers 数位dp

Good Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2615    Accepted Submission(s): 806


Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
 

Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 

Sample Input
  
  
2 1 10 1 20
 

Sample Output
  
  
Case #1: 0 Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:   4856  4855  4854  4853  4852 
 
题意:求一个区间内每个位上和能够被10整除的数的个数。

思路:设dp[pos][mod] 为当前考虑pos位,即第(pos+1)位,之前数位和的模值为mod 时,这(pos+1)个数位与之前数位的组合有多少个数位和能被10整数的个数。

详见代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int MAXN=25;
ll n,m;
int bit[MAXN];
ll dp[MAXN][MAXN];
ll dfs(int pos,int mod,int flag)
{
    if(pos == -1) return mod == 0;
    if(flag && dp[pos][mod]!=-1) return dp[pos][mod];
    ll ans=0;
    int x=flag ? 9: bit[pos];
    for(int i=0;i<=x;i++){
        int k=(mod+i)%10;
        ans+=dfs(pos-1,k,flag || i<x);
    }
    if(flag) dp[pos][mod]=ans;
    return ans;
}
ll solve(ll x)
{
    int len=0;
    if(x==0)
        bit[len++]=0;
    while(x)
    {
        bit[len++]=x%10;
        x/=10;
    }
    return dfs(len-1,0,0);
}
int main()
{
    //freopen("text.txt","r",stdin);
    int T,kase=0;
    scanf("%d",&T);
    memset(dp,-1,sizeof(dp));
    while(T--){
        kase++;
        scanf("%I64d%I64d",&n,&m);
        ll ans1= n==0 ? 0: solve(n-1);
        ll ans2=solve(m);
        printf("Case #%d: %I64d\n",kase,ans2-ans1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值