PAT甲级真题及训练集(13)--1027. Colors in Mars (20)

1027. Colors in Mars (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456

提交代

/**
作者:一叶扁舟
时间:16:53 2017/6/26
思路:因为输入范围为[0-168],10,11,12用ABC表示

*/
#include <stdio.h>
#include <stdlib.h>
#define HEX 13//要转成的进制数

int main(){
	int a, b, c;//输入的三个数据
	char result[20] = {'0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'A', 'B', 'C'};
	char finalResult[10];
	scanf("%d%d%d", &a, &b, &c);
	int count = 0;
	finalResult[0] = result[a / HEX];
	finalResult[1] = result[a % HEX];
	finalResult[2] = result[b / HEX];
	finalResult[3] = result[b % HEX];
	finalResult[4] = result[c / HEX];
	finalResult[5] = result[c % HEX];
	//输出结果
	printf("#");
	for (int i = 0; i < 6; i++){
		printf("%c", finalResult[i]);
	}
	system("pause");
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值