A1027——Colors in Mars(火星上颜色的RGB值)

A color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. People in Mars use radix 13 (0-9 and A-C)  Now given a color in three decimal numbers (each between 0 and 168,即十三进制数字最多为2位), you are supposed to output their Mars RGB values.

一种颜色用6位13进制数字表示,前两位为红色,中间两位为绿色,最后两位为蓝色。

输入格式:

Each input file contains one test case which occupies a line containing the three decimal color values.

输出格式:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

英文字母需要大写,如果某个颜色只有1位数字,在高位填充0

Sample Input

15 43 71

Sample Output

#123456

代码

#include<stdio.h>

char F(int a){
    char c;
    if(a==10) c='A';
    if(a==11) c='B';
    if(a==12) c='C';
    return c;
}


void print(int color){
    int r1=color/13;
    int r2=color%13;
    if(r1>9){
            if(r2>9) printf("%c%c",F(r1),F(r2));
            else printf("%c%d",F(r1),r2);

    }else{
        if(r2>9) printf("%d%c",r1,F(r2));
        else printf("%d%d",r1,r2);
    }
}



int main(){
    int red,green,blue;
    scanf("%d%d%d",&red,&green,&blue);
    printf("#");
    print(red);
    print(green);
    print(blue);

return 0;
}

~

直接写了两个函数,一个用来把超过9的数字转换成大写字母,一个用来打印

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值