TOJ 1335 HDU 1242 ZOJ 1649 营救天使 / 广搜+优先队列

营救天使

时间限制(普通/Java):1000MS/10000MS     运行内存限制:65536KByte

描述

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

输入

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, "x" stands for a guard, and "r" stands for each of Angel's friend.

Process to the end of the file.

输出

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

样例输入

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

样例输出

13

#include <stdio.h>
#include <string>
#include <iostream>
#include <queue>
#define MAX 210
#define inf 0x7fffffff
using namespace std;

char a[MAX][MAX];
int map[MAX][MAX];
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};//代表上 下 左 右 
int n,m;
int Min;
struct point
{
	int x;
	int y;
	int step;//步数 
	friend bool operator <(point a,point b)
	{
		return a.step > b.step;//优先队列 时间少的先搜 
	}
}s,e;


void bfs()
{
	priority_queue <point> q;
	memset(map,0,sizeof(map));
	q.push(s);
	while(!q.empty())
	{
		point p = q.top();	
		q.pop();
		if(p.x == e.x && p.y == e.y)
		{
			if(p.step < Min)
				Min = p.step;
			return ;
		}
		for(int i = 0;i < 4; i++)
		{
			point t;
			t.x = p.x + dir[i][0];
			t.y = p.y + dir[i][1];
			if(t.x >= 0 && t.x < n && t.y >= 0 && t.y < m && a[t.x][t.y] != '#' && map[t.x][t.y] == 0)
			{
				t.step = p.step + 1;
				map[t.x][t.y] =  1;//标记走过了不再走  
				if(a[t.x][t.y] == 'x')
				{
					t.step++;
					a[t.x][t.y] = '.';//不管那个人 杀掉了就死了 这里wrong了一次 
				}				
				q.push(t);
			}
		}
	}
}
main()
{
	int i,j;
	while(scanf("%d %d %d",&n,&m)!=EOF)
	{
		Min = inf;
		for(i = 0;i < n; i++)
		{
			scanf("%s",a[i]);
			for(j = 0;j < m; j++)
			{
				if(a[i][j] == 'a')
				{
					e.x = i;
					e.y = j;
				}
			}
		}
		for(i = 0;i < n; i++)
		{
			for(j = 0;j < m; j++)
			{
				if(a[i][j] == 'r')
				{
					s.x = i;
					s.y = j;			
					bfs();				
				}
			}
		}
		if(Min != inf)
			printf("%d\n",Min);
		else
			puts("Poor ANGEL has to stay in the prison all his life.");
	}
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值