TOJ 1335 优先队列

1335: 营救天使

时间限制(普通/Java):1000MS/10000MS 内存限制:65536KByte

描述

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel’s friends want to save Angel. Their task is: approach Angel. We assume that “approach Angel” is to get to the position where Angel stays. When there’s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

输入

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. “.” stands for road, “a” stands for Angel, “x” stands for a guard, and “r” stands for each of Angel’s friend.

Process to the end of the file.

输出

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing “Poor ANGEL has to stay in the prison all his life.”

样例输入

7 8
#.#####.
#.a#…r.
#…#x…
…#…#.#
#…##…
.#…

样例输出

13

题目来源

ZOJ Monthly 2003
解题思路:这题一开始没用优先队列,WA了n次,一直WA的可以看看下面的案例,并且这题只有一个小朋友,可以百度一下C++队列的一些用法。
4 3
…r
.#x
.#x
.ax

3

3 2
a#
xr
r#

6

#include <iostream>
#include <string.h>
#include <cstdio>
#include <queue>
using namespace std;
char a[201][201];
int dir[4][2]= {0,1,0,-1,1,0,-1,0};	//定义四个方向
int ax,ay,n,m;
struct node{
    int x,y,step;
    friend bool operator < (node a,node b){ //重载了队列的优先级,step小的优先级高
        return  a.step > b.step;
    }
}now,next;
int bfs(int x,int y){
    priority_queue<node>q;			
    now.x=x, now.y=y, now.step=0;	
    q.push(now);		//设置第一个点属性并且压入队列
    a[x][y]='#';		//标记已走过
    while(!q.empty()){
    	now = q.top();	//队头赋给now
        q.pop();		//弹出
        for(int i=0 ; i<4 ; i++){	//四个方向遍历
            int nx = now.x + dir[i][0];
            int ny = now.y + dir[i][1];
            if(nx>=0&&nx<n&&ny>=0&&ny<m&&a[nx][ny]!='#'){	//条件满足
                 next;
                next.x=nx, next.y=ny, next.step=now.step+1;	
                if(a[nx][ny]=='x')	// 当遇到陷阱时时间要加1
                    ++next.step;
                if(a[nx][ny]=='r'){ // 天使位置,输入步数
                	cout << next.step << endl;
                	return 0;             	
                }                    
                a[nx][ny]='#';
                q.push(next);
            }
        }
    }
    return 1;
}
int main(){
    while(cin >> n >> m){
        for(int i=0 ; i<n ;i++){
            getchar();
            for(int j=0 ; j<m ;j++){	//输入标记
                a[i][j]=getchar();
                if(a[i][j]=='a')  ax=i, ay=j;
            }
        }
        if(bfs(ax,ay))
            cout << "Poor ANGEL has to stay in the prison all his life." << endl;
    }
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值