TOJ 3053 OJ 2244 ZOJ 1088 System Overload / 约瑟夫

System Overload

时间限制(普通/Java):1000MS/3000MS     运行内存限制:65536KByte

描述

Recently you must have experienced that when too many people use the BBS simultaneously, the net becomes very, very slow.
To put an end to this problem, the Sysop has developed a contingency scheme for times of peak load to cut off net access for some buildings of the university in a systematic, totally fair manner. Our university buildings were enumerated randomly from 1 ton. XWB is number 1, CaoGuangBiao (CGB) Building is number 2, and so on in a purely random order.
Then a number m would be picked at random, and BBS access would first be cut off in building 1 (clearly the fairest starting point) and then in everymth building after that, wrapping around to 1 after n, and ignoring buildings already cut off. For example, ifn=17 and m=5, net access would be cut off to the buildings in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off CGB Building last (after all, this is where the best programmers come from), so for a given n, the random number m needs to be carefully chosen so that building 2 is the last building selected.

Your job is to write a program that will read in a number of buildingsn and then determine the smallest integer m that will ensure that our CGB Building can surf the net while the rest of the university is cut off.

输入

The input file will contain one or more lines, each line containing one integern with 3 <= n < 150, representing the number of buildings in the university.
Input is terminated by a value of zero (0) for n.

输出

For each line of the input, print one line containing the integerm fulfilling the requirement specified above.

样例输入

3
4
5
6
7
8
9
10
11
12
0

样例输出

2
5
2
4
3
11
2
3
8
16

学习了约瑟夫公式 不用模拟

#include <stdio.h>
bool judge(int n,int k)//公式  
{
	int m = 0,i;
	for(i = 2; i < n; i++)// 第一个是1 已经选定了 所以少循环一次 
		m = (m + k) % i;
	if(m + 2 == 2)//本来是加一的加一是从0开始 这题再加一是它是从2开始的 第一个已经选定了
		return true;
	return false;
}
int main()
{
	int n,i;
	while(scanf("%d",&n),n)
	{
		for(i = 1; ;i++)
		{
			if(judge(n,i))
			{
				printf("%d\n",i);
				break;
			}
		}
	}
	return 0;
}

约瑟夫公式


 

#include <stdio.h>
int main()
{
    int n, m, i, s = 0;
    printf ("N M = ");
    scanf("%d%d", &n, &m);
    for (i = 2; i <= n; i++)
    {
        s = (s + m) % i;
    }
    printf ("\nThe winner is %d\n", s+1);
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值