poj 3041 Asteroids

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15847 Accepted: 8635

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

简单的二分匹配

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>

#define eps 1e-8
#define op operator
#define MOD  10009
#define MAXN  100100
#define INF 0x7fffffff
#define MEM(a,x)    memset(a,x,sizeof a)
#define ll __int64

using namespace std;

int n,k;
int mp[510][510];
int link[510];
int vis[510];
int ans;

bool dfs(int u)
{
    for(int i=1;i<=n;i++)
    {
        if(mp[u][i]&&!vis[i])
        {
            vis[i]=1;
            if(link[i]==-1||dfs(link[i]))
            {
                link[i]=u;
                return 1;
            }
        }
    }
    return 0;
}

void hungary()
{
    MEM(link,-1);
    for(int i=1;i<=n;i++)
    {
        MEM(vis,0);
        if(dfs(i))  ans++;
    }
}

int main()
{
//freopen("ceshi.txt","r",stdin);
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        MEM(mp,0);
        int u,v;
        for(int i=0;i<k;i++)
        {
            scanf("%d%d",&u,&v);
            mp[u][v]=1;
        }
        ans=0;
        hungary();
        printf("%d\n",ans);
    }
    return 0;
}



   

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值