poj 3041 二分图最小点集覆盖

          二分图最小点集覆盖==二分图最大匹配,,知道了这个公式,这道题就很水了。。。。。。。题目:

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8487 Accepted: 4532

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2
ac代码:

#include <iostream>
#include <algorithm>
#include <vector>
#include <string.h>
#include <cstdio>
using namespace std;
vector<int> ss[505];
int flag[505],visted[505];
bool dfs(int x){
	for(int i=0;i<ss[x].size();++i){
		if(!visted[ss[x][i]]){
		  visted[ss[x][i]]=1;
		  if(!flag[ss[x][i]]||dfs(flag[ss[x][i]])){
		    flag[ss[x][i]]=x;
			return true;
		  }
		}
	}
	return false;
}
int main(){
	
	int n,m;
  while(~scanf("%d%d",&n,&m)){
    memset(ss,0,sizeof(ss));
	memset(flag,0,sizeof(flag));
	
	int x,y;
	while(m--){
	  scanf("%d%d",&x,&y);
	  ss[x].push_back(y);
	}
	int sum=0;
	for(int i=1;i<=n;++i){
		memset(visted,0,sizeof(visted));
	  if(dfs(i))
		  sum++;
	}
	printf("%d\n",sum);
  }
  return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值