poj 2689 Prime Distance

Language:
Prime Distance
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13337 Accepted: 3543

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.


求出一段范围内 距离最近的两个素数 距离最远的两个素数  或者没有相邻的素数

由于给出左右边界可能达到的值太大 所以 不可能把所有的素数都筛出来 但是区间的值不大

所以可以把区间内的素数都找出来 

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>

#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 50010
#define INF 99999999
#define ll long long
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)

using namespace std;

int Read()
{
    char ch;
    int a = 0;
    while((ch = getchar()) == ' ' | ch == '\n');
    a += ch - '0';
    while((ch = getchar()) != ' ' && ch != '\n')
    {
        a *= 10;
        a += ch - '0';
    }
    return a;
}

void Print(int a)    //输出外挂
{
     if(a>9)
         Print(a/10);
     putchar(a%10+'0');
}

int prime1[MAXN],nprime1;
bool isprime[20*MAXN];
void init()
{
    nprime1=0;
    MEM(isprime,1);
    for(ll i=2;i<MAXN;i++)
    {
        if(isprime[i])
        {
            nprime1++;
            prime1[nprime1]=i;
            for(ll j=i*i;j<MAXN;j+=i)
                isprime[j]=0;
        }
    }
}

ll l,u;
ll prime2[1000001];
int nprime2;
void make_prime()
{
    MEM(isprime,1);
    ll b;
    for(ll i=1;i<=nprime1;i++)
    {
        b=l/prime1[i];
        while(b*prime1[i]<l||b<=1)
            b++;
        for(ll j=b*prime1[i];j<=u;j+=prime1[i])
        {
            if(j>=l)
                isprime[j-l]=0;
        }
    }
    if(l==1)
        isprime[0]=0;
}

void solve()
{
    ll mi=INF,mx=-INF;
    ll minl,minr,maxl,maxr;
    make_prime();
    nprime2=0;
    for(int i=0;i<=u-l;i++)
    {
        if(isprime[i])
        {
            nprime2++;
            prime2[nprime2]=i+l;
        }
    }
    if(nprime2<=1)
        printf("There are no adjacent primes.\n");
    else
    {
        for(int i=1;i<nprime2;i++)
        {
            if(prime2[i+1]-prime2[i]<mi)
            {
                mi=prime2[i+1]-prime2[i];
                minl=prime2[i]; minr=prime2[i+1];
            }
            if(prime2[i+1]-prime2[i]>mx)
            {
                mx=prime2[i+1]-prime2[i];
                maxl=prime2[i]; maxr=prime2[i+1];
            }
        }
        printf("%lld,%lld are closest, %lld,%lld are most distant.\n",minl,minr,maxl,maxr);
    }
}

int main()
{
    //fread;
    init();
    while(scanf("%lld%lld",&l,&u)!=EOF)
    {
        solve();
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值