Language:
Balanced Lineup
Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height. Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group. Input
Line 1: Two space-separated integers,
N and
Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive. Output
Lines 1..
Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input 6 3 1 7 3 4 2 5 1 5 4 6 2 2 Sample Output 6 3 0 |
n个数 求任意区间中最大值减最小值的差
用RMQ求出区间的最大最小值 相减就可以了。。。
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>
#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 50010
#define MAXM 100010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)
using namespace std;
int a[MAXN];
int dmax[MAXN][30],dmin[MAXN][30];
int n,q;
void RMQinit()
{
for(int i=0;i<n;i++)
{
dmax[i][0]=dmin[i][0]=a[i];
}
for(int j=1;(1<<j)<=n;j++)
for(int i=0;i+(1<<j)-1<n;i++)
{
dmax[i][j]=max(dmax[i][j-1],dmax[i+(1<<(j-1))][j-1]);
dmin[i][j]=min(dmin[i][j-1],dmin[i+(1<<(j-1))][j-1]);
}
}
int MAXRMQ(int l,int r)
{
int k=0;
while((1<<(k+1))<=r-l+1) k++;
return max(dmax[l][k],dmax[r-(1<<k)+1][k]);
}
int MINRMQ(int l,int r)
{
int k=0;
while((1<<(k+1))<=r-l+1) k++;
return min(dmin[l][k],dmin[r-(1<<k)+1][k]);
}
int main()
{
// fread;
while(scanf("%d%d",&n,&q)!=EOF)
{
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
RMQinit();
while(q--)
{
int l,r;
scanf("%d%d",&l,&r);
l--; r--;
printf("%d\n",MAXRMQ(l,r)-MINRMQ(l,r));
}
}
return 0;
}