Choose the best route
Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
Sample Output
1 -1
最短路问题,因为起点不止一个,但终点只有一个,所以,可以从后往前算;
寻找和点S距离最短的点,做下标记,然后更新未标记的点和S的距离;重复这一步骤。。。
注意是有向边,点是从一到n;
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define N 1005
#define Inf 1000000
int n,m,s;
int map[N][N],mark[N],dis[N];
void diskstra()
{
int i,index,min;
for(i=0;i<=n;i++)
dis[i]=map[s][i];
mark[s]=1;
while(1)
{
min=Inf;
index=s;
for(i=0;i<=n;i++)
if(!mark[i]&&dis[i]<min)
{
index=i;
min=dis[i];
}
if(index==s)
return ;
mark[index]=1;
for(i=0;i<=n;i++)
{
if(!mark[i]&&dis[i]>map[index][i]+dis[index])
dis[i]=map[index][i]+dis[index];
}
}
}
int main()
{
int i,j,w,end;
while(scanf("%d%d%d",&n,&m,&s)!=EOF)
{
for(i=0;i<=n;i++)
for(j=0;j<=n;j++)
{
if(i==j)
map[i][j]=0;
else
map[i][j]=Inf;
}
int p,q,t;
while(m--)
{
scanf("%d%d%d",&p,&q,&t);
if(map[q][p]>t)
map[q][p]=t;
}
memset(mark,0,sizeof(mark));
diskstra();
scanf("%d",&w);
int min=Inf;
while(w--)
{
scanf("%d",&end);
if(dis[end]<min)
min=dis[end];
}
if(min==Inf)
printf("-1\n");
else
printf("%d\n",min);
}
return 0;
}