poj 1753 Flip Game

Flip Game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28190 Accepted: 12221

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

题意:一个4*4的棋盘放满黑白棋子,每次选择一个棋子,把它和它相邻的棋子状态翻转(改变颜色),目标是用最少的步数使16个棋子颜色相同。

解题思路:

每个格子有两种状态,棋盘共有2^16=65536个状态;

又改变格子状态时有16种选择,选择某个位置的棋子改变状态就是一个异或操作。

每个棋子有两个状态可以用二进制表示,如黑为1,白为0;

由位运算规则:1^1=0,0^1=1; 

具体代码如下:

 

#include"stdio.h"
#include"iostream"
#include"queue"
using namespace std;
#define N 65536
int dir[4][2]={1,0,-1,0,0,-1,0,1};
int change[16];     
int visit[N];
struct node    // 用优先队列,一般队列也能过
{
	int state,step;
	friend bool operator<(node a,node b)
	{
		return a.step>b.step;
	}
};
void inti()        //若提前求出16个操作状态存入数组可以省去该函数
{
	int i,j,x,y,t,temp,k=0;
	for(i=0;i<4;i++)
	{
		for(j=0;j<4;j++)
		{
			temp=0;
			temp^=(1<<((3-i)*4+3-j));
			for(t=0;t<4;t++)
			{
				x=dir[t][0]+i;
				y=dir[t][1]+j;
				if(x<0||y<0||x>3||y>3)
					continue;
				temp^=(1<<((3-x)*4+3-y));
			}
			change[k++]=temp;
		}
	}
}
int bfs(int t)
{
	int i;
	memset(visit,0,sizeof(visit));
	priority_queue<node>q;
	node cur,next;
	cur.state=t;
	cur.step=0;
	q.push(cur);
	visit[t]=1;
	while(!q.empty())
	{
		cur=q.top();
		q.pop();
		if(cur.state==0||cur.state==N-1)
			return cur.step;
		for(i=0;i<16;i++)
		{
			next.state=cur.state^change[i];
			next.step=cur.step+1;
			if(!visit[next.state])
			{
				q.push(next);
				visit[next.state]=1;
			}
		}
	}
	return -1;
}
int main()
{
	int i,j,t,ans;
	inti();
	char chess[5][5];
	while(scanf("%s",chess[0])!=-1)
	{
		for(i=1;i<4;i++)
			scanf("%s",chess[i]);
		t=0;
		for(i=0;i<4;i++)
			for(j=0;j<4;j++)
			{
				if(chess[i][j]=='b')
					t^=1<<((3-i)*4+3-j);       //此处把异或改为加也行,
			}
		ans=bfs(t);
		if(ans==-1)
			printf("Impossible\n");
		else
			printf("%d\n",ans);
	}
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值