poj 3252 Round Numbers

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8194 Accepted: 2865

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation ofN has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤Start <Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish

Sample Input

2 12

Sample Output

6

 

解题思路:

1、一个数n,长度为len的二进制数,先求出长度为len-1的round number;用排列组合求解,0的个数要大于等于长度的一半。切记:最高位不为0。

2、从次高位开始枚举,(若该位置为1,则把它改为0,则改变后的数必定小于n. 如:11***** 改为10*****)0的个数大于等于(len+1)/2,用排列组合计算。


#include<stdio.h>
#define N 35
#define Max(a,b) ((a)>(b)?(a):(b))
int c[N][N];
void inti()
{
	int i,j;
	for(i=0;i<33;i++) //c[0][0]=1;当枚举到某个二进制数末位为0正好为round number,sum+=c[0][0]应该加一   

	{
		c[i][0]=c[i][i]=1; 
		for(j=1;j<i;j++)
			c[i][j]=c[i-1][j]+c[i-1][j-1];
	}
}
int solve(int n)
{
	int i,j,len=0,sum=0;
	int bit[N];
	while(n)
	{
		bit[++len]=n%2;
		n/=2;
	}
	for(i=1;i<len;i++)         //1、长度小于len时
		for(j=(i+1)/2;j<i;j++) //0的个数大于等于总数的一半,且不能全为0
			sum+=c[i-1][j];    //除去最高位1,i-1个位置,j个0 
	int one=1,zero=0;
	for(i=len-1;i>0;i--)       //2、枚举长度为len时
	{
		if(bit[i])    //这一位是1,改为0, 
		{
			zero++;
			for(j=Max(0,(len+1)/2-zero);j<i;j++)   //0的个数不能为负
				sum+=c[i-1][j];       //第i位至len位已经固定,
			zero--;
			one++;
		}
		else
			zero++;
	}
	return sum;
}
int main()
{
	int a,b;
	inti();
	while(scanf("%d%d",&a,&b)!=-1)
	{
		int t=solve(b+1)-solve(a);
		printf("%d\n",t);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值