hdu 1081 To The Max(最大子矩阵和)

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7533    Accepted Submission(s): 3647


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15
 

动态规划求最大子矩阵和,把二维的转化为一维的就好做了。

1、首先看一位数组a[]求最大字段和,b记录以i结尾的数组最大字段和;

显然若b<0(此时存储的是以i-1为结尾的最大和),有b=a[i];  否则b+=a[i]; 

2、转化为一维的数组就是枚举某一连续几行,把每一列的值加起来存到一个元素中,

这些元素就构成了一个一维数组。

然后,按照一维数组求最大字段和的方法求解即可。


#include"stdio.h"
#include"math.h"
#include"string.h"
#define N 105
int Maxsum(int a[],int m)
{                         //求一维数组的最大字段和
	int i,s=0,max=a[0];
	for(i=0;i<m;i++)
	{
		if(s>=0)
			s+=a[i];
		else
			s=a[i];
		if(s>max)
			max=s;
	}
	return max;
}
int main()
{
	int n,i,j,k;
	int b[N];
	int a[N][N];
	while(scanf("%d",&n)!=-1)
	{
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
				scanf("%d",&a[i][j]);
		int max=a[0][0];
		for(i=0;i<n;i++)    
		{
			memset(b,0,sizeof(b));
			for(j=i;j<n;j++)        //从某一行开始加到末行
			{
				for(k=0;k<n;k++)         //求解相加过程中的最大字段和
					b[k]+=a[j][k];
				int t=Maxsum(b,n);
				if(t>max)
					max=t;
			}
		}
		printf("%d\n",max);
	}
	return 0;
}








  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值