poj 2349 Arctic Network (prim算法)

Arctic Network
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10525 Accepted: 3470

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

最小生成树prim算法


#include"stdio.h"
#include"math.h"
#include"string.h"
#include"queue"
#include"algorithm"
using namespace std;
#define N 505
const double inf=1e12;
double g[N][N],dis[N];
bool mark[N];
int n,m;
struct node
{
    double x,y;
}e[N];
double fun(int i,int j)
{
    double x,y;
    x=e[i].x-e[j].x;
    y=e[i].y-e[j].y;
    return sqrt(x*x+y*y);
}
void prim(int s)
{
    int i,j,u;
	double min;
    memset(mark,0,sizeof(mark));
    mark[s]=1;
    for(i=0;i<m;i++)
    {
        dis[i]=g[s][i];
    }
	dis[s]=0;
    for(j=1;j<m;j++)
    {
        u=s;
        min=inf;
        for(i=0;i<m;i++)
        {
            if(!mark[i]&&dis[i]<min)
            {
                min=dis[i];
                u=i;
            }
        }
        mark[u]=1;
        for(i=0;i<m;i++)
        {
            if(!mark[i]&&dis[i]>g[u][i])
                dis[i]=g[u][i];
        }
    }
    sort(dis,dis+m);        //从小到大排序
    printf("%.2f\n",dis[m-n]);
}
int main()
{
    int T,i,j;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<m;i++)
        {
            scanf("%lf%lf",&e[i].x,&e[i].y);
        }
        for(i=0;i<m;i++)
        {
            for(j=0;j<i;j++)
            {
                g[i][j]=g[j][i]=fun(i,j);
            }
            g[i][i]=inf;       //注意初始化
        }
        prim(0);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值