hdu 1757 A Simple Math Problem(矩阵快速幂)

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2780    Accepted Submission(s): 1649


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
  
  
45 104
 
图解:



这个图来自: http://www.cnblogs.com/wally/archive/2013/03/01/2938305.html

</pre><pre name="code" class="cpp">#include"iostream"
#include"stdio.h"
#include"string.h"
#include"algorithm"
#include"queue"
#include"vector"
using namespace std;
#define N 10
#define LL __int64
struct Mat
{
    LL mat[N][N];
};
int n=10,M;
int f[N];
Mat operator *(Mat a,Mat b)
{
    int i,j,k;
    Mat c;
    memset(c.mat,0,sizeof(c.mat));
    for(i=0;i<n;i++)
    {
        for(j=0;j<n;j++)
        {
            c.mat[i][j]=0;
            for(k=0;k<n;k++)
            {
                c.mat[i][j]+=(a.mat[i][k]*b.mat[k][j])%M;
            }
            c.mat[i][j]%=M;
        }
    }
    return c;
}
int fun(Mat&a,int k)
{
    int i;
    Mat ans;
    memset(ans.mat,0,sizeof(ans.mat));
    for(i=0;i<n;i++)
        ans.mat[i][i]=1;
    while(k)
    {
        if(k&1)
            ans=ans*a;
        k>>=1;
        a=a*a;
    }
    LL s=0;
    for(i=0;i<n;i++)
    {
        s+=(ans.mat[0][i]*f[n-1-i])%M;
    }
    return s%M;
}
int main()
{
    int i,k;
    while(scanf("%d%d",&k,&M)!=-1)
    {
        Mat a;
        memset(a.mat,0,sizeof(a.mat));
        for(i=0;i<n;i++)
        {
            f[i]=i;
            scanf("%I64d",&a.mat[0][i]);
        }
        for(i=1;i<n;i++)          //第一行开始往下是单位矩阵
            a.mat[i][i-1]=1;
        printf("%d\n",fun(a,k-9));

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值