hdu 4442 Physical Examination (排序)

Physical Examination

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5813    Accepted Submission(s): 1625


Problem Description
WANGPENG is a freshman. He is requested to have a physical examination when entering the university.
Now WANGPENG arrives at the hospital. Er….. There are so many students, and the number is increasing!
There are many examination subjects to do, and there is a queue for every subject. The queues are getting longer as time goes by. Choosing the queue to stand is always a problem. Please help WANGPENG to determine an exam sequence, so that he can finish all the physical examination subjects as early as possible.
 

Input
There are several test cases. Each test case starts with a positive integer n in a line, meaning the number of subjects(queues).
Then n lines follow. The i-th line has a pair of integers (ai, bi) to describe the i-th queue:
1. If WANGPENG follows this queue at time 0, WANGPENG has to wait for ai seconds to finish this subject.
2. As the queue is getting longer, the waiting time will increase bi seconds every second while WANGPENG is not in the queue.
The input ends with n = 0.
For all test cases, 0<n≤100000, 0≤a i,b i<2 31.
 

Output
For each test case, output one line with an integer: the earliest time (counted by seconds) that WANGPENG can finish all exam subjects. Since WANGPENG is always confused by years, just print the seconds mod 365×24×60×60.
 

Sample Input
  
  
5 1 2 2 3 3 4 4 5 5 6 0
 

Sample Output
  
  
1419
Hint
In the Sample Input, WANGPENG just follow the given order. He spends 1 second in the first queue, 5 seconds in the 2th queue, 27 seconds in the 3th queue, 169 seconds in the 4th queue, and 1217 seconds in the 5th queue. So the total time is 1419s. WANGPENG has computed all possible orders in his 120-core-parallel head, and decided that this is the optimal choice.


题意:对于每个bi,除了第一个选择的,都是每秒加一个bi的,求最小的和。

我们考虑两个相邻的项目i,j:

(ai,bi),(aj,bj),在进行这两项检查时,这两个项目的先后顺序不会影响其它项目的消耗时间。

因此,我们只需要得出这两项先后关系就好了。若i<j,则ai+ai*bj+aj<aj+aj*bi+ai;即是(ai/bi)<(aj/bj);

按这个关系排序就OK了。

</pre><pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define N 100005
#define LL __int64
const LL mod=365*24*60*60;
struct node
{
    int a,b;
    double c;
}g[N];
bool cmp(node a,node b)
{
    return a.c<b.c;
}
int main()
{
    int i,n;
    while(scanf("%d",&n),n)
    {
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&g[i].a,&g[i].b);
            g[i].c=1.0*g[i].a/g[i].b;
        }
        sort(g,g+n,cmp);
        LL sum=0;
        for(i=0;i<n;i++)
        {
            sum=(sum+sum*g[i].b+g[i].a)%mod;
        }
        printf("%I64d\n",sum);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值