uva 10453 Make Palindrome(DP)

Problem B : Make Palindrome

From:UVA, 10453

Problem A

Make Palindrome

Input: standard input

Output: standard output

Time Limit: 8 seconds

By definition palindrome is a string which is not changed when reversed. "MADAM" is a nice example of palindrome. It is an easy job to test whether a given string is a palindrome or not. But it may not be so easy to generate a palindrome.


Here we will make a palindrome generator which will take an input string and return a palindrome. You can easily verify that for a string of length 'n', no more than (n-1) characters are required to make it a palindrome. Consider "abcd" and its palindrome "abcdcba" or "abc" and its palindrome "abcba". But life is not so easy for programmers!! We always want optimal cost. And you have to find the minimum number of characters required to make a given string to a palindrome if you are allowed to insert characters at any position of the string.

Input

Each input line consists only of lower case letters. The size of input string will be at most 1000. Input is terminated by EOF.


Output

For each input print the minimum number of characters and such a palindrome seperated by one space in a line. There may be many such palindromes. Any one will be accepted.

Sample Input

abcdaaaaabcaababababaabababapqrsabcdpqrs

Sample Output

3 abcdcba0 aaaa2 abcba1 baab0 abababaabababa9 pqrsabcdpqrqpdcbasrqp
<br />
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
using namespace std;

const int maxn = 1105;
int dp[maxn][maxn];
int vis[maxn][maxn] = {0};
int v;
//string ini;
char ini[maxn];


int DP(int i , int j){
	//cout << i << " " << j << endl;
	if(i == j) return 0;
	if(i > j) return 0;
	if(vis[i][j] == v) return dp[i][j];
	int tem = 0;
	if(ini[i] == ini[j]){
		tem = DP(i+1 , j-1);
		//cout << i << " " << j << "=" << tem.ans << endl;
	}else{
		int d1 = DP(i+1 , j) , d2 = DP(i , j-1);
		if(d1 <= d2){
			tem = d1+1;
		}else{
			tem = d2+1;
		}
		//cout << i << " " << j << "=" << tem.ans << endl;
	}
	vis[i][j] = v;
	return dp[i][j] = tem;
}

void print(int i , int j){
	if(i == j){
		printf("%c" , ini[i]);
		return;
	}
	if(i > j){
		printf("");
		return;
	}
	if(ini[i] == ini[j]){
		printf("%c" , ini[i]);
		print(i+1 , j-1);
		printf("%c" , ini[i]);
	}else{
		if(DP(i+1 , j) <= DP(i , j-1)){
			printf("%c" , ini[i]);
			print(i+1 , j);
			printf("%c" , ini[i]);
		}else{
			printf("%c" , ini[j]);
			print(i , j-1);
			printf("%c" , ini[j]);
		}
	}
}

int main(){
	v = 1;
	while(scanf("%s" , ini) != EOF){
		printf("%d ",DP(0 , strlen(ini)-1));
		print(0 , strlen(ini)-1);
		printf("\n");
		//printf("%d %s\n" , ans.sum , ans.ans.c_str());
		v++;
	}
	return 0;
}
<br /><span id="_xhe_temp" width="0" height="0"><br /></span>
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值