uva10104 - Euclid Problem

 Euclid Problem 

The Problem

From Euclid it is known that for any positive integers A and B there exist such integers X and Y thatAX+BY=D, where D is the greatest common divisor of A and B. The problem is to find for given A and Bcorresponding XY and D.

The Input

The input will consist of a set of lines with the integer numbers A and B, separated with space (A,B<1000000001).

The Output

For each input line the output line should consist of three integers X, Y and D, separated with space. If there are several such X and Y, you should output that pair for which |X|+|Y| is the minimal (primarily) andX<=Y (secondarily).

Sample Input

4 6
17 17

Sample Output

-1 1 2
0 1 17
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;

#define ll long long
ll A , B , D , X , Y;

ll gcd(ll a , ll b){
    if(b == 0){
        X = 1;
        Y = 0;
        return a;
    }else{
        ll t = gcd(b , a%b);
        ll tX = Y;
        Y = X-(a/b)*Y;
        X = tX;
        return t;
    }
}

void computing(){
    int T = false;
    if(A < B){
        T = true;
        swap(A , B);
    }
    D = gcd(A , B);
    if(T) swap(X , Y);
    cout << X << " " << Y << " " << D << endl;
}

int main(){
    while(cin >> A >> B){
        computing();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值