11478 - Halum(差分约束)

Problem H
Halum
Time Limit : 3 seconds
 


You are given a directed graph G(V,E) with a set of vertices and edges. Each edge (i,j) that connects some vertex i to vertex j has an integer cost associated with that edge.
 
Define the operation Halum(v, d) to operate on a vertex v using an integer d as follows: subtract d from the cost of all edges that enter v and add d to the cost of every edge that leaves v.

As an example of that operation, consider graph G that has three vertices named (1, 2, 3) and two edges. Edge (1, 2) has cost -1, and edge (2,3) has cost 1. The operation Halum(2,-3) operates on edges entering and leaving vertex 2.  Thus, edge (1, 2) gets cost -1-(-3)=2 and the edge (2, 3) gets cost 1 + (-3) = -2.

Your goal is to apply the Halum function to a graph, potentially repeatedly, until every edge in the graph has at least a certain cost that is greater than zero. You have to maximize this cost.

 

 
 Input  
 

Two space-separated integers per case: V(V≤500) and E(E≤2700)E lines follow. Each line represents a directed edge using three space-separated integers (u, v, d). Absolute value of cost can be at most 10000.

 
   
 Output 
 

If the problem is solvable, then print the maximum possible value. If there is no such solution print “No Solution”. If the value can be arbitrary large print “Infinite”

 
   
 Sample InputSample Output  
 

2 1
1 2 10
2 1
1 2 -10
3 3
1 2 4
2 3 2
3 1 5
4 5
2 3 4
4 2 5
3 4 2
3 1 0
1 2 -1


Infinite
Infinite
3
1



 

每个点是一个未知数,设a->b,cost=c,最小变得值为x(即答案)则:c+a-b >= x =》 b-a <= c-x,二分这个x得出答案。


#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
#include <cmath>
using namespace std;

const int inf = 1000000000;
const int maxn = 520;
const int maxe = 15*maxn;
const int INF = 100000;
struct edge{
    int u , v , c , next;
    edge(int a = 0 , int b = 0 , int cost = 0 , int n = -1){
        u = a, v = b , c = cost , next = n;
    }
}e[maxe];
vector<edge> ini_e;
int V , E , cnt , head[maxn] , vis[maxn] , vt[maxn] , dis[maxn];

void add(int u , int v , int cost){
    e[cnt] = edge(u , v , cost , head[u]);
    head[u] = cnt++;
}

void init(){
    cnt = 0;
    for(int i = 0; i < maxn; i++){
        vis[i] = 0;
        vt[i] = 0;
        head[i] = -1;
        dis[i] = inf;
    }
}

void initial(){
    init();
    ini_e.clear();
}

void readcase(){
    int u , v , c;
    for(int i = 0; i < E; i++){
        scanf("%d%d%d" , &u , &v , &c);
        ini_e.push_back(edge(u , v , c));
    }
}

void build_graph(int m){
    init();
    for(int i = 1; i <= V; i++) add(0 , i , 0);
    for(int i = 0; i < ini_e.size(); i++){
        add(ini_e[i].u , ini_e[i].v , ini_e[i].c-m);
    }
}

bool spfa(int start){
    queue<int> q;
    vis[start] = 1;
    vt[start]=1;
    dis[start] = 0;
    q.push(start);
    while(!q.empty()){
        int u = q.front();
        q.pop();
        vis[u] = 0;
        if(vt[u] > sqrt(V*1.0)+1) return false;
        for(int i = head[u]; i != -1; i = e[i].next){
            int v = e[i].v;
            int c = e[i].c;
            if(dis[v] > dis[u]+c){
                dis[v] = dis[u]+c;
                if(!vis[v]){
                    vis[v] = 1;
                    vt[v]++;
                    q.push(v);
                }
            }
        }
    }
    return true;
}

void computing(){
    int l = 0 , r = INF;
    while(l < r){
        int mid = (l+r)/2;
        //cout << l << " " << r << " " << mid << endl;
        build_graph(mid);
        if(spfa(0)) l = mid+1;
        else r = mid;
    }
    if(l <= 1) printf("No Solution\n");
    else if(l != INF) printf("%d\n" , l-1);
    else printf("Infinite\n");
}

int main(){
    while(~scanf("%d%d" , &V , &E)){
        initial();
        readcase();
        computing();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值