hdu2817

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2831    Accepted Submission(s): 873


Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 

Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 

Sample Input
  
  
2 1 2 3 5 1 2 4 5
 

Sample Output
  
  
5 16
 
因为前三个数比较大,用scanf("%lf%lf%lf",&a,&b,&c)
参考了 点击打开链接
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MOD 200907

int quick_mod(long long a, int b){
	int ret = 1;
	for( ; b; ){
		if(b&1){
			ret = (ret*(a%MOD))%MOD;
		}
		a = ((a%MOD)*(a%MOD))%MOD;
		b>>=1;
	}
	return ret;
}

int main(){
	double a, b, c;
	int k, n;
	cin>>n;
	while(n--){
		scanf("%lf%lf%lf%d", &a, &b, &c, &k);
		long long a1, b1, c1;
		a1 = (long long)a;
		b1 = (long long)b;
		c1 = (long long)c;
		if(2*b==a+c){
			int result = (a1%MOD + ((k%MOD)-1)*((b1-a1)%MOD))%MOD;
			printf("%d\n", result);
		}else{
			long long q = b1/a1;
			int result = quick_mod(q, k-1);
			int ans = ((a1%MOD)*result)%MOD;
			printf("%d\n", ans);
		}
			
	}
	return 0;
}


  
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值