hdu 2817 A sequence of numbers

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3284    Accepted Submission(s): 986


Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 

Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 

Sample Input
  
  
2 1 2 3 5 1 2 4 5
 

Sample Output
  
  
5 16
 

快速幂取模法:
(链接:)

#include<stdio.h>
#define M 200907

__int64 pow(__int64 q,__int64 n)   // 快速取模
{  
    __int64 sum=1;  
    while(n>0)  
    {  
        if(n%2==1)  
            sum=(sum*q)%M;
        q=(q*q)%M;  
        n/=2;  
    }  
    return sum;  
}  


int main ()
{
	int T;
	__int64 n,a[10],d,q,l;
	scanf("%d",&T);
	while(T--)
	{
		for(int i=1;i<=3;i++)
			scanf("%I64d",&a[i]);
		scanf("%I64d",&n);
		
		if(a[3]-a[2]==a[2]-a[1])    // 等差数列
		{  
			d=a[3]-a[2];
			l=(a[1]+(n-1)*d)%M;
		}
 
		else                       // 等比数列
		{
		    q=a[2]/a[1];
		    l=(a[1]*pow(q,n-1))%M;
		}
		printf("%I64d\n",l);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值