A sequence of numbers
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3284 Accepted Submission(s): 986
Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.
You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
Output
Output one line for each test case, that is, the K-th number module (%) 200907.
Sample Input
2 1 2 3 5 1 2 4 5
Sample Output
5 16
快速幂取模法:
(链接:)
#include<stdio.h>
#define M 200907
__int64 pow(__int64 q,__int64 n) // 快速取模
{
__int64 sum=1;
while(n>0)
{
if(n%2==1)
sum=(sum*q)%M;
q=(q*q)%M;
n/=2;
}
return sum;
}
int main ()
{
int T;
__int64 n,a[10],d,q,l;
scanf("%d",&T);
while(T--)
{
for(int i=1;i<=3;i++)
scanf("%I64d",&a[i]);
scanf("%I64d",&n);
if(a[3]-a[2]==a[2]-a[1]) // 等差数列
{
d=a[3]-a[2];
l=(a[1]+(n-1)*d)%M;
}
else // 等比数列
{
q=a[2]/a[1];
l=(a[1]*pow(q,n-1))%M;
}
printf("%I64d\n",l);
}
return 0;
}